更多>>关于我们

西安鲲之鹏网络信息技术有限公司从2010年开始专注于Web(网站)数据抓取领域。致力于为广大中国客户提供准确、快捷的数据采集相关服务。我们采用分布式系统架构,日采集网页数千万。我们拥有海量稳定高匿HTTP代理IP地址池,可以有效获取互联网任何公开可见信息。

您只需告诉我们您想抓取的网站是什么,您感兴趣的字段有哪些,你需要的数据是哪种格式,我们将为您做所有的工作,最后把数据(或程序)交付给你。

数据的格式可以是CSV、JSON、XML、ACCESS、SQLITE、MSSQL、MYSQL等等。

更多>>官方微博

西安鲲之鹏
陕西 西安

加关注

  • 【视频演示】受客户委托对淘宝APP-淘鲜达店铺商品数据抓取的可行性进行评估。实测可行(销量也可以采集到),如录屏网页版。  西安鲲之鹏的微博视频 ​​​​

    发布时间:2020-02-21 17:44:07
  • 【经验分享】Win8下安装VMware出现"error1316 指定账户已存在"问题的解决

    似乎是之前的安装有注册表残留(在控制面板已安装程序列表里看不到),尝试安装了多次,持续出现"error1316 指定账户已存在"问题,网上有VMware注册表清理工具试了也不管用。

    后来使用Windows Installer CleanUp Utility(Windows Installer 清理实用工具包,简称MSICUU)解决了问题。MSICUU会显示你以前没卸干净的软件列表(如附图1网页版), 然后选择你想完全卸掉的项目 ,卸载了就可以了。

    附MSICUU的下载链接>>> O【Windows Installer CleanUp Utility下载】2...
    发布时间:2020-02-19 17:14:47
  • 【视频】携程酒店价格采集对比工具定制版演示
    该最新定制版(2020年)使用Google Chrome Dev Protocol(非Selenium + webdirver模式)实现,不会暴露navigator.webdriver等各种特征,不容易被识别。
    对比17年的版本:采用的是(Selenium + phantomjs)能够被反爬虫机制识别,关注有虚假价格情况,失败率也高。  西安鲲之鹏的微博视频

    发布时间:2020-02-18 15:24:40
  • 【经验分享】一例正则表达式效率低问题的分析

    一直以来都觉得正则表达式的效率非常高,今天遇到一例正则匹配耗时特长的情况,mark一下。
    目标是判断目标网页(大小约350KB)中是否有符合以下要求的子串:
    "至少要有一个不为'的字符<div class="tips_unresult">"

    想当然的写出了如下的代码:
    re.compile(r'[^\']+<div[^<>]+class="tips_unresult">').search(html)
    测试的时候发现这一步耗时特别长,记了一下时,竟然花了差不多10秒,很是诧异。

    后来试着修改了下正则式,如下:
    re.compile(r'[^\']<div[^<>]+class="tips_unresult">').search(html)
    和第一次的相比,区别在于:这里只匹配"<div..."前面有一个非'字符即可,而第一步是匹配"<div..."前面有一个或多个非'字符。
    这次只用了0.004秒,结果相差了1600多倍!

    PS:[汗]第一次的那个代码在以往一个的爬虫中曾执行过70多万次[汗],以前竟然没有发现问题,还以为时间都花在webkit加载页面上了...这样一算竟然多花了近一周的时间。

    独立的测试代码和运行截图如附图网页版。
    发布时间:2020-02-17 17:57:15
  • 【经验分享】“supervisor实现无限重试”中的坑

    背景:Debian 10系统,Wifi联网,需要实现系统启动时自动启动autossh。
    问题:如果网络未连接成功(例如,Wifi是在用户登录之后才会连接),启动autossh会失败退出。因此不能直接使用rc.local(在网络连接成功之前就执行了)。于是想到使用supervisor,让其不断的重试,当网络连接正常时就autossh就会正常被启动了,配置如附图1网页版。但是发现supervisor最多只重试了3次就放弃了。

    查询supervisor configuration文档(http://supervisord.org/configuration.html?highlight=startretries)得知startretries参数用于控制每次启动的重试次数,默认值是3。

    另外还有一个autorestart参数,如果设置为true,则无条件重启(If true, the process will be unconditionally restarted when it exits, without regard to its exit code.)。但我设置了autorestart为true后,还是只重试了3次。

    为什么呢?在autorestart参数注意事项里看到了如下说明:
    autorestart controls whether supervisord will autorestart a program if it exits after it has successfully started up (the process is in the RUNNING state).

    意思就是说目标program必须成功启动过一次(被标记过为RUNNING状态),autorestart机制才会起作用。

    由于本案例中supervisor服务启动的时候网络连接还没建立成功,所以目标program(autossh)首次启动(3次重试)会失败,这样autorestart机制就没起作用。

    怎么破?
    首先我们要弄清楚supervisor是怎么判断目标程序成功启动了呢。
    在startsecs参数的说明里我们可以看到:
    The total number of seconds which the program needs to stay running after a startup to consider the start successful (moving the process from the STARTING state to the RUNNING state).
    也就是只有目标程序启动保持运行超过startsecs秒才会被认为启动成功了(标记状态为RUNNING)。startsecs默认值是1。本例中autossh由于没有网络连接闪退了,所以supervisor认为其启动失败。

    弄清原理之后,就好办了,我们实现一个这样的脚本:
    (1)先判断网络连接是否正常(可以使用ping),如果不正常则等待10秒(只要超过startsecs值即可)后退出。
    (2)如果网络连接正常,则启动autossh。

    #!/bin/bash

    #
    检测网络是否通畅
    ping -c 1  www.baidu.com
    if [ $? -eq 0 ]
    then
      # 网络正常,启动autossh
      echo "Network is ready"
      sudo /bin/su qi -l -c "/usr/bin/autossh -M 6777 -N -D 127.0.0.1:1080 目标主机SSH参数"
    else
      #
    网络不通,等待11秒后退出
      echo "Network is not ready."
      sleep 11s
      exit 1
    fi

    实测成功。

    附Supervisor Configuration File文档链接:http://supervisord.org/configuration.html
    发布时间:2020-02-15 23:14:20
  • 发布时间:2020-02-14 21:06:44
  • 【经验分享】python2 pip安装frida-tools,在安装prompt-toolkit依赖时出现"No matching distribution found for prompt-toolkit<4.0.0,>=3.0.3 (from frida-tools)"问题(如附图1网页版)的解决。

    问题分析:需要的prompt-toolkit版本是 <4.0.0,>=3.0.3,而python 2库中prompt-toolkit的最高版本才是2.0.10。 查询得知"prompt_toolkit 3.0 requires at least Python 3.6." (来源:https://python-prompt-toolkit.readthedocs.io/en/master/),3.0以后版本需要至少python 3.6。

    怎么破?
    (1)下载frida-tools源码包。
    (2)修改setup.py文件,如附图2网页版,将prompt-toolkit的版本要求去掉。
    (3)sudo python setup.py install。
    发布时间:2020-02-11 18:55:01
  • 【视频演示】受客户委托对淘宝APP直播弹幕数据抓取的可行性进行评估。实测可行,如录屏网页版。  西安鲲之鹏的微博视频 ​​​​

    发布时间:2020-02-11 15:38:51
  • 【经验分享】Linux下如何查看服务器的型号,出厂日期?
    可以使用dmidecode命令查看BIOS信息来实现。
    e.g.
    # 查看机器型号
    sudo dmidecode -s system-product-name
    #
    查看出厂日期
    sudo dmidecode -s bios-release-date

    如图1网页版为我最近折腾的TDE上网本的情况;
    如图2网页版为公司某服务器的情况;
    如图3网页版为阿里云服务器的情况;

    关于dmidecode命令的详细说明见这里 >>> http://t.cn/A6Pemztx
    发布时间:2020-02-08 13:32:58
  • 【经验分享】这两天被冠状病毒困在家,翻出了一台10年前的上网本(TDE山寨货),配置如图1(i686 CPU 1.6GHz,1G RAM)。
    折腾了一下安装各种系统,可能驱动兼容性问题,期间遇到了各种问题,总结如下:

    (1)Chrome OS:
    安装比较顺利,运行也比较流畅,进入系统之后就是一个谷歌浏览器。
    但由于国内无法使用Google相关服务,使用起来比较麻烦,放弃。

    (2)Android系列:
    Bliss OS 下载 32位,安装后无法进入桌面环境。
    PrimeOS,没有32位的版本,无法安装。

    (3)Linux发行版:
    Linux Mint 19.3 cinnamon 32位,进入桌面后巨卡,无法正常使用,后来试了兼容模式启动情况好一些。
    Ubuntu 16.04.6 Desktop i386,安装过程复制文件后期卡死,无后文。
    Debian 10.2.0 i386,赞一个,安装过程很流畅(“配置软件包管理器”那步耗时较长),使用也很流畅。

    最终选定使用Debian 10。
    发布时间:2020-02-08 11:17:45
当前位置:首页 >技术文章 >
如何程序化设置安卓设备的HTTP代理
发布时间:2019-06-08

在模拟操作安卓App进行数据采集的时候,我们需要给安卓设备(或模拟器)设置HTTP代理,手动设置的方法网上有很多介绍(WIFI属性->高级选项->代理设置)。对于需要频繁切换代理IP的情况,手动设置显然不太可能,那么如何通过程序进行HTTP代理设置呢?

前面我们曾介绍过“Drony + 动态PAC文件”实现安卓设备下的自动代理切换(http://www.snutzpark.com/html/articles/20190113/694.html),但是该方案也无法直接通过程序来控制。

下面再介绍两种可以通过程序控制安卓设备HTTP代理的方案:

1.使用AndroidProxySetter APP

通过adb调用AndroidProxySetter这个安卓APP,来实现代理的设置和清除功能,不需要ROOT权限。关于AndroidProxySetter的使用方法,详见这里:https://github.com/jpkrause/AndroidProxySetter,APK下载地址:https://github.com/jpkrause/AndroidProxySetter/releases

下面是用法举例:

# 设置设备的代理为192.168.1.8:8888
adb shell am start -n tk.elevenk.proxysetter/.MainActivity -e host 192.168.1.8 -e port 8888
# 清除代理配置
adb shell am start -n tk.elevenk.proxysetter/.MainActivity -e clear true

PS:上述命令中未指定WIFI名称,proxysetter将会使用默认连接的WIFI。

注意:实测发现,该方案只支持安卓4.x及以下版本。

由于proxysetter依赖于https://github.com/shouldit/android-proxy/tree/master/android-proxy-library,而在android-proxy-library主页有说明:"supported all Android versions: 1.x - 2.x - 3.x - 4.x"。

2.通过配置系统的http_proxy参数

注意:该方法适合于安卓5.x及以上版本。

下面是用法举例:

设置代理为192.168.1.8:8888:

adb shell settings put global http_proxy 192.168.1.8:8888

PS:所有安卓版本都支持。
安卓4.x及以下版本请慎用该方法,一旦设置代理后,无法轻易清除。

清除代理:

adb shell settings delete global http_proxy
adb shell settings delete global http_proxy_host
adb shell settings delete global http_proxy_port

PS:只有安卓5.x及以上版本才支持delete命令。
安卓4.x版本清除http_proxy代理设置的方法可以参考:https://stackoverflow.com/questions/31807559/undo-setting-proxy-via-settings-global-in-android,需要ROOT权限。
清除代理后需要重启设备才能生效。

上述命令实际上是对/data/data/com.android.providers.settings/databases/settings.db这个SQLite数据库进行了添加/删除操作。
如下图网页版为settings.db中http代理的相关参数:

 

总结一下,Android 4.x及以下版本,使用AndroidProxySetter,Andorid 5.x及以上版本使用http_proxy属性。下面给出一个我们在项目中使用的Python代码片段,它能够根据设备的安卓版本,自动选用合适的方法进行代理设置和代理清除。

# coding: utf-8
import os
import time
import subprocess
class ADBProxyManager:
"""通过ADB设置安卓设备的HTTP代理
"""
def __init__(self):
# 设备安卓主版本号
self.device_android_version = self.get_device_android_version()
def get_device_android_version(self):
"""获取设备的安卓版本
"""
ret = subprocess.check_output('adb shell getprop ro.build.version.release', shell=True)
if '.' in ret:
return int(ret.strip().split('.')[0])
else:
raise Exception(u'获取设备的安卓版本号失败.')
def ensure_install_proxysetter(self):
"""确保安装了AndroidProxySetter
"""
while True:
apps_installed = subprocess.check_output('adb shell pm list packages').splitlines()
if 'package:tk.elevenk.proxysetter' not in apps_installed:
print u'该手机尚未安装"WIFI代理设置器", 将自动安装.'
os.system('adb install ./bin/proxy-setter.apk')
time.sleep(10)
else:
break
def set_proxy(self, host, port):
"""设置代理
host - 代理IP;
port - 代理端口;
"""
if self.device_android_version <= 4:
# 安卓4.x之下可以使用AndroidProxySetter来设置代理
print u'当前设备安卓版本号为{}.*, 将使用AndroidProxySetter来配置代理'.format(self.device_android_version)
# 确保安装了AndroidProxySetter
self.ensure_install_proxysetter()
os.system('adb shell am start -n tk.elevenk.proxysetter/.MainActivity -e host {} -e port {}'.format(host, port))
time.sleep(10)
else:
# 安卓4.x之上版本使用global http_proxy参数来设置代理
print u'当前设备安卓版本号为{}.*, 将通过系统global http_proxy属性来配置代理'.format(self.device_android_version)
os.system('adb shell settings put global http_proxy {}:{}'.format(host, port))
time.sleep(5)
def clear_proxy(self):
"""清除代理
"""
if self.device_android_version <= 4:
# 安卓4.x之下可以使用AndroidProxySetter来设置代理
print u'当前设备安卓版本号为{}.*, 将使用AndroidProxySetter来配置代理'.format(self.device_android_version)
# 确保安装了AndroidProxySetter
self.ensure_install_proxysetter()
os.system('adb shell am start -n tk.elevenk.proxysetter/.MainActivity -e clear true')
time.sleep(5)
else:
# 安卓4.x之上版本使用global http_proxy参数来设置代理
print u'当前设备安卓版本号为{}.*, 将通过系统global http_proxy属性来配置代理'.format(self.device_android_version)
os.system('adb shell settings delete global http_proxy')
os.system('adb shell settings delete global global_http_proxy_host')
os.system('adb shell settings delete global global_http_proxy_port')
time.sleep(5)

 

特别说明:本文旨在技术交流,请勿将涉及的技术用于非法用途,否则一切后果自负。如果您觉得我们侵犯了您的合法权益,请联系我们予以处理。
☹ Disqus被Qiang了,之前所有的评论内容都看不到了。如果您有爬虫相关技术方面的问题,欢迎发到我们的问答平台:http://spider.snutzpark.com/
QQ在线客服
欢迎咨询,点击这里给我发送消息。
欢迎咨询,点击这里给我发送消息。

加微信咨询